SLAMM EXERCISE

The Use of GIS to Support Operation of the
Source Loading and Management Model (SLAMM) for
Analysis of Urban Non-Point Source Pollution
Dan Rodman
David Hart
Brea Lemke
University of Wisconsin-Madison
Email: dahart@wisc.edu

Objective
Examine the use of ArcView desktop GIS to support operation of the Source Loading and Management
Model (SLAMM) for planning and management of nonpoint source pollution in urban areas.

Software Needed
• ArcView version 3.x from Environmental Systems Research Institute (ESRI). Retail price $1195.
(http://www.esri.com/software/arcview/index.html). Additional training available for ArcView 3.x
(http://www.lic.wisc.edu/training/).
Note: This exercise was written using ArcView 3.3. There may be minor differences noted
between software versions.
• WinSLAMM from PV and Associates. Retail price $200. (http://www.winslamm.com).
Additional training is available for SLAMM (on a rotating basis at the UW)
(http://epdweb.engr.wisc.edu/).
Note: This exercise was written using WinSLAMM 8.5. There may be minor differences noted
between software versions.

Background
According to the EPA, “runoff from urban areas is the leading source of impairments to surveyed
estuaries and the third largest source of water quality impairments to surveyed lakes. In addition,
population and development trends indicate that by 2010 more than half of the Nation will live in
coastal towns and cities. Runoff from these rapidly growing urban areas will continue to degrade
coastal waters (1). High levels of pollution prevented people from swimming safely at coastal beaches
on more than 12,000 occasions from 1988 through 1994, and the latest National Water Quality
Inventory reports that one-third of surveyed estuaries (areas near the coast where seawater and
freshwater mixing occurs) are damaged (2).”
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Hydrologic models for non-point source (NPS) pollution are important tools for analyzing the relation
among land use, pollutants generated by those uses, and mitigation measures to reduce pollution.
Models are useful not only for estimating current NPS pollution, but predicting future levels based on
changing land use and mitigation measures.
Geographic Information Systems (GIS) are able to store and analyze large amounts of spatial data, such
as the land use, soil type and even topographical information required by NPS pollution models.
Currently, the most common use of GIS with NPS pollution models is as a data preparation tool, as
opposed to using GIS itself to perform the modeling (3). In this exercise, GIS will be used to provide a
summary table of total land areas having a given land use and soil type. This information will serve as
input into the SLAMM NPS pollution model.
References
1. EPA, 1997. NonPoint Source Pointers - Managing Urban Runoff. EPA Office of Water, document
EPA841-F-96-004G (http://www.epa.gov/owow/nps/facts/point7.htm)
2. EPA, 1997. NonPoint Source Pointers - Protecting Coastal Waters from Nonpoint Source
Pollution. EPA Office of Water, document EPA841-F-96-004E
(http://www.epa.gov/owow/nps/facts/point5.htm)
3. Maidment, David R. (1993) GIS and Hydrologic Modeling. Environmental Modeling with GIS
(Chapter 14). Ed. by Goodchild, M.F., Parks, B.O. and Steyaert, L.T. Oxford University Press,
New York.

SLAMM Overview (taken from the abstract in the SLAMM documentation)
The Source Loading and Management Model (SLAMM) was originally developed to better understand
the relationships between sources of urban runoff pollutants and runoff quality. It has been continually
expanded since the late 1970s and now includes a wide variety of source area and outfall control
practices (infiltration practices, wet detention ponds, porous pavement, street cleaning, catchbasin
cleaning, and grass swales). SLAMM is strongly based on actual field observations, with minimal
reliance on theoretical processes that have not been adequately documented or confirmed in the field.
SLAMM is mostly used as a planning tool, to better understand sources of urban runoff pollutants and
their control.
Special emphasis has been placed on small storm hydrology and particulate washoff in SLAMM.
Many currently available urban runoff models have their roots in drainage design where the emphasis
is with very large and rare rains. In contrast, stormwater quality problems are mostly associated with
common and relatively small rains. The assumptions and simplifications that are legitimately used
with drainage design models are not appropriate for water quality models. SLAMM therefore
incorporates unique process descriptions to more accurately predict the sources of runoff pollutants and
flows for the storms of most interest in stormwater quality analyses. However, SLAMM can be
effectively used in conjunction with drainage design models in order to incorporate the mutual benefits
of water quality controls on peak flow rates.
SLAMM has been used in many areas of North America and has been shown to accurately predict
stormwater flows and pollutant characteristics for a broad range of rains, development characteristics,
and control practices. As with all stormwater models, SLAMM needs to be accurately calibrated and
then tested (verified) as part of any local stormwater management effort.
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Basic Concept of SLAMM Calculations
SLAMM divides land up into 6 broad land use classes (residential, institutional, commercial,
industrial, open, and freeways). Within each class of land use, the land area is further classified into 14
“source areas” (such as turf, roofs, parking, playgrounds, freeways…). Source areas are further
classified according to their runoff behavior (for
example, whether roofs are flat or pitched, and whether
they drain directly to the drainage system or drain onto
sandy or clayey soils).
For each of these land use / source area / runoff
behavior combinations, its total land area is determined.
A set of coefficients for water runoff, particulate solids
loadings and pollutant loadings are determined for it as
well. The creators of SLAMM have done extensive
testing in various cities to derive the coefficients that
we will use (hence the empirical, or observation-based,
nature of SLAMM).
For each of these runoff-unique land types, SLAMM makes the basic calculations shown in the table
(presented conceptually, not exactly). Computed volumes and mass loadings are summed to give
values for an entire watershed or sewershed.
SLAMM also models related
phenomena, such as the effect of
runoff mitigation measures (e.g.,
detention ponds), and the
statistical uncertainty in pollutant
concentrations derived from
different land use & source areas.
We will not examine those
capabilities.
See Appendix A at the end of this
handout for a more detailed
description of the SLAMM
parameter files.

Concept of SLAMM Calculations
Rainfall Volume x Runoff Coefficient = Water Runoff Volume
Water Runoff Volume x Particulate Solids Concentration =
Particulate Solids Loading* (in pounds)
Water Runoff Volume (or Particulate Solids Loading) x
Pollutant Probability Distribution = Pollutant Loading
* An additional Particulate Residue Reduction factor reduces the amount of
particulate solid ultimately leaving the drainage system, to take into account
particulate settling in the drainage system.
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Role of GIS in Preparing SLAMM Data
SLAMM assumes there is very detailed
land information. Interpreted literally,
the entire watershed could be
quantified roof by roof, parking lot by
parking lot, etc.
To simplify, typical distributions of
SLAMM land uses, source areas and
runoff behaviors have been established
for approximately twenty general land
use categories. This information is compiled in SLAMM Standard Land Use (SLU) files.
Thus, our task with GIS is not to quantify the area of every roof and parking lot. Rather, we will
quantify the area of each general land use class (and its soil characteristics – clayey or sandy) within a
sewershed. These general land use categories and soil data will then be associated with SLAMM
“Standard Land Use” data files.

Spatial Data Requirements
Required Data
Land Use: Land use codes must be related to the Standard Land Use categories defined in SLAMM.
Sewersheds: Sewersheds define the study boundaries. They can be created from analysis of topography
(such as a digital elevation model) and the storm sewer network.
Optional Data
Soils: The sandy or clayey characteristic of soils is considered in SLAMM to affect runoff coefficients.
In this exercise, it is assumed that all soils are clayey, because most urban soils are well-compacted and
have low infiltration rates. If actual soils data were included in the analysis, the county-level SSURGO
soils data would be most appropriate to match the high spatial detail of the land use data.
However, in the SLAMM data structure, soils are an inherent characteristic in each source area (for
example, if a roof source type is not connected directly to the drainage system, then a sandy or clayey
soil type, along with other runoff characteristics, must be specified for that roof type). It does not
appear easy to change the soil type of source areas through some batch process.
Planimetric Features (building outlines, sidewalks, driveways...): This could theoretically be used
to quantify source area statistics (such as what percentage of residential land use is roofs), either for
original measurement or verification of existing SLAMM Standard Land Use files. However, the
runoff behavior of these source areas, such as roof slope and connection to drainage system, could not
be determined from most planimetric feature data.
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Original Data Sets for This Exercise
FILE NAME
FORMAT
Malu.shp
Polygon shapefile
Maswbnd.shp
Polygon Shapefile
Lu2slammcode.
Dbase table
dbf
RoadfactorDbase table
mimals12.dbf

DESCRIPTION
Marquette land use
Marquette Sewersheds
A table relating each Marquette land use code to a
single-letter SLAMM land use code
Road area factor per Marquette land use code within
sewershed MIMALS12

Data Sets Created through This Exercise
FILE NAME
FORMAT
DESCRIPTION
Maluswb.shp
Polygon shapefile
Merged land use and sewersheds
Mimalu12Dbase table
Total land area for each land use within MIMALS12
landuse.dbf
sewershed (SLAMM ladn use codes, road factors and
land area per soil type are added)
Mimalu12.dbf
Dbase table
Mimalu12-landuse table, exported & purged of
uneeded fields.
Mimalu12.txt
Text file
ASCII-format text file from Mimalu12.dbf
mimalu12.pla
Text file
Mimalu12.txt, with SLAMM file extension “pla”
Spatial Reference System for Marquette, Michigan Data:
Coordinate Units: U.S. Survey Feet (1 meter = 3.2808333333 U. S. Survey Feet)
Datum: NAD27 (Clarke 1866 Ellipsoid)
Projection: State Plane, Michgan (old) West Zone
Projection Parameters:
Transverse Mercator
Central Meridian: exactly 88d45’00” West (-88.75 degrees)
Reference Latitude: exactly 41d30’00” North (41.5 degrees)
Scale Factor: 0.9999090909
False Easting: exactly 500,000 U.S. Survey Feet (152400.3048 meters)
False Northing: exactly 0
Summary of Procedures:
I. Merge Land Use and Sewershed Themes
II. Create Land Use Statistics for a Sewershed
III. Reformat Land Use Statistics for Use in SLAMM
IV. Create or Obtain Appropriate SLAMM Parameter Files (ran, ppd, prr, rsv, psc, cpz)
V. Modify Standard Land Use Files in SLAMM for Needed Land Use Categories
VI. Run SLAMM Batch Editor to Estimate Pollutant Loadings
VII. Display Output in GIS
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I. Merge Land Use and Sewershed Themes
A. Initiate ArcView and Load Spatial Data
1) Start the ArcView 3.x program.
2) If the “Welcome to ArcView GIS” window appears, select “Create a new project, with a new
View”. If this window does not appear, from ArcView’s project menu highlight “VIEWS” and
click the “New” button.
3) Activate (click on) the view window, “View1”.
4) From “View1”’s main menu, select “View” then “Add Theme” from the pull-down menu.
5) Add the following themes: MALU.SHP (land use) and MASWBND.SHP (sewersheds).
6) Set distance units. To do this, from the “View” menu select “Properties”. In the new window, set
the Map Units and Distance Units to “Feet”. In this window, also change the name of the View
from “View 1” to “View: Land Use & Sewersheds”. Click “OK”.
7) Set the working directory. From the “File”
menu select “Set Working Directory”. In the
new window set the working directory to the
folder where you copied the SLAMM Exercise
files. In doing so, all new files will be saved
there by default. Click “OK”.
8) In the view window, turn on the two themes. This can be done by clicking on the small box by
each of the theme’s names, thus adding a check mark.
9) If one theme is not visible, it does not have the highest viewing priority on the hierarchy of layers.
Layers that are on the top of the legend have the highest viewing priority, and are in essence, placed
on top of the other layers. If there are elements in the layer that have solid fill, they will cover the
layers that are lower in the legend hierarchy. To see a theme on top of other themes, left click (and
hold down) on the layer’s name, then drag the layer to the top of the list of layers.

B. Merge Land Use and Sewershed Themes
In modeling, it is useful to determine the total area of each type of
land use within each sewershed. To perform this analysis, the two
datasets are overlaid using a spatial “intersection.” The result is a
single theme whose polygons contain both land use and sewershed
attributes from the original themes.
1) From the “File” menu, select “Extensions”. In the new window, under “Available Extensions”,
scroll down to “Geoprocessing” and check it; click “OK”.
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2) From the “View” menu, select “Geoprocessing Wizard”. In the window that appears, enter the
following parameters:
•
•
•
•
•

Select “Intersect Two Themes”;
Click the “Next” button.
Specify the Input Theme as
“Malu.shp”.
Select the Overlay Theme as
“Maswbnd.shp”.
Specify the Output File as
“Maluswb.shp”.
Click the “Finish” button to
execute the intersection command.
The processing may take a few
minutes.
3) Save the ArcView project as “Marqslamm.apr”, by using the “Save As” command from
the “File” menu.

C. Update Polygon Areas in the Attribute Table
ArcView’s Intersection command correctly splits polygons, but it does not update polygon areas or
perimeters in the attribute table. Instead, the area and perimeter numbers, from the two original
datasets, are simply copied as if they were nominal attributes like land use or sewershed names.
Quantifying land area is critical for runoff computations in the SLAMM model, so the area values must
be corrected.
1) In the window, “View: Land Use & Sewersheds”, turn on and activate the new theme
(Maluswb.shp). To activate it, click on its name so that a highlighted box appears around the whole
name (in addition to the check in the small box that turns the theme on).
2) From the “Theme” menu, select “Table”. The attribute table for the active shapefile (maluswb.shp)
will appear.
Examine the area and perimeter values in the MALUSWB attribute table. There are two sets of
area and perimeter values – one from each of the land use and sewershed themes. Notice that
many records (polygons) share the exact same area and perimeter values. These are not the recalculated areas and perimeters of the intersected polygons; rather, they are the original areas
and perimeters of the pre-intersection polygons.
3) With the table window active, from the “Table” menu select “Start Editing”.
4) Delete the first area and perimeter fields. To do this, select the left-most “area” field by clicking on
its gray header box; from the “Edit” menu select “Delete Field”; click “Yes” to confirm the
command. Now, select the left-most “perimeter” field by clicking in its gray header box. Again
from the “Edit” menu select “Delete Field”. Click “Yes” to confirm the deletion.
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5) Clear the current selection, to make sure no records are selected. From the “Edit” menu select
“Select None”. This process is done to assure that the subsequent command applies to all records,
not just the selected records.
6) In the attribute table, select the remaining “Area”
field (click on the field’s title); from the “Field”
menu select “Calculate”. In the calculation screen
that appears, enter the following parameters:
o In the [Area] = box, type
“[Shape].ReturnArea”
o Click “OK”.
7) Again in the attribute table, select the remaining
“Perimeter” field; from the “Field” menu select
“Calculate”. Enter the following parameters in
the Field Calculator screen:
o In the [Area] = box, type “[Shape].ReturnLength”
o Click “OK”.
8) From the “Table” menu, select “Stop Editing”, thus saving all edits.
9) From the “File” menu, select “Save Project”.

II. Create Land Use Statistics for a Sewershed
A. Relate SLAMM Land Use Codes to Existing Land Use Codes
For each land use class, SLAMM references a Standard Land Use (SLU) file which describes the
distribution of source areas and runoff behavior. SLAMM requires a single letter code as a reference to
the SLUs. The “translation” from existing land use codes into single-letter SLAMMCODE is
accomplished with a separate table defining the relation between the two code systems. This
translation table is appended, or “joined”, in ArcView terminology, to the land use summary table
previously generated. The table below lists the relations.
It is important to note that this particular Marquette land use classification system was designed to
match the Standard Land Use files utilized by SLAMM. In a study area where existing land use
classification might not match SLAMM SLU categories, there are two options: 1) relate land use to the
most similar SLU; or 2) create new SLUs with source area distributions which represent the local land
use classes.
NOTE: Due to the single-letter that relates land use classes to SLU files, SLAMM is limited to 26
different Standard Land Use files (codes A to Z) for a single run. If an existing land use
classification system has more than 26 classes, not every class could be associated with a unique
SLU.
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In subsequent steps of this exercise, a table of total area per land use type will be derived. It is
important to translate to SLAMM land use codes before computing the area totals because SLAMM
doesn’t handle more than one record (line of data) per land use for a sewershed. For example,
cemeteries and parks are both to be coded as SLAMMCODE “H”, because they have similar
characteristics. If the land use data was not translated to SLAMM codes before producing the total area
table, there would be a record in the table for both CEM and PARK. After translating CEM and PARK
to “H”, there would be two records for land use “H”. Thus, SLAMM would give incorrect results as it
would only process the last record.

Standard Land Use Classes and Codes
"LU" Land Use Code
CDT
CEM
CST
FREE
HOSP
HRNA
HRWA
LI
LR
MF
MI
MISC
MOBR
MRNA
MRWA
OP
OSUD
PARK
SC
SCH

SLAMMCODE
S
K
F
G
U
M
N
O
C
D
E
J
P
A
B
T
I
H
R
Q

Land Use Description
Commercial Downtown
Cemetery *
Commercial Strip *
Freeway
Hospital *
High Density Residential (no Alley) *
High Density Residential (with Alley)
Light Industrial
Low Density Residential *
Multi-Family Residential *
Medium Industrial *
Miscellaneous *
Mobile Homes
Medium Density Residential (no Alley) *
Medium Density Residential (with Alley)
Office Park
Open Space *
Park *
Shopping Center
School *

(Classes with an astrix* are used in this exercise)

In this step we will join the land use code translation table (lu2slammcode.dbf) to the land use theme:
1) Open the project window; from the “Window” menu select “Marqslamm.apr”. In the project
window, select the “Tables” icon and press the “Add” button. Navigate to the “lu2slammcode.dbf”
file and click “OK”.
2) In the attribute table of the newly added database file, select the “Lu” field by clicking on its gray
header bar.
3) Now open (and activate) the “maluswb” table. Use the “Window” pull-down menu to
return to “View: Land Use & Sewersheds”. Make sure the “maluswb” theme is active and
GIS & SLAMM: Page 9 of 27

click on the “Open Theme Table” button. While in the attribute table of “maluswb”, select the
“Lu” field by clicking on its gray header bar.
4) To bring the two tables together, from the “Table” menu, select “Join”.
5) Examine the “Attributes of maluswb.shp” table; notice that there are no SLAMM codes for roads
or water. This is because there is an absence of those land use codes in the “lu2slammcode” table.
This issue will be looked at later in the exercise.
NOTE: In this relation between tables, the first table selected (lu2slammcode.dbf) is joined to the
latter table selected (mimal2-landuse.dbf) using the “key” field (Lu). It is important to
understand which table will be used as the output table for the “join” as a mistake may result in a
loss of records in the database. It is always the table from which the “Join” command is
prompted that will serve as the output table, or the table to which the other tabular information
will be added. The loss of data may occur (depending on database organization) if there is more
than one “Lu” code associated with one SLAMM code. A comparison of total area (see Section
II, Part C) would verify whether this type of omission had occurred.
B. Select Polygons from One Sewershed (MIMALS12)
This analysis will be limited to the MIMALS12 sewershed. Therefore, the polygons within that
sewershed will be selected and summarized in a separate table.
1) With the attribute table for “Maluswb.shp” still active, from the “Table” menu select
“Query” or click on the “Query Builder” icon.

2) In the Query Builder dialog box, build the
expression ([Id] = "MIMALS12") and select
the “New Set” button.
Close the Query Builder window.

MIMALS12
Sewershed

3) Open the View window (View: Land Use &
Sewersheds) and look at the “Maluswb.shp” theme
(remember that this theme is the intersected land
use and sewersheds records). The polygons that
pertain to the selected records should appear in
yellow. These selected records depict the area in
the MIMALS12 sewershed.

GIS & SLAMM: Page 10 of 27

C. Aggregate Polygon Areas by Land Use
SLAMM only requires the total area of each hydrologically-distinct land use within the sewershed. It
does not require information about the spatial distribution of those land uses. Therefore, a new table
will be generated with the aggregated area per land use within the selected sewershed.
1) Activate the “Attributes of Maluswb” table. Either click on the “Open Theme Table” icon in the
View, or from the “Window” menu select “Attributes of Maluswb.shp”.
2) Make sure that the previously selected records are still selected (in yellow). Activate the
“SLAMMCODE” field (click on the gray box at the top of its column).
NOTE: If you accidentally clicked within the table so that only one or a few records are selected,
you will have to repeat the selection process above with the Query Builder. If all the features of
the MIMALS12 sewershed are not select, the area aggregation will not include the desired
records (polygons) in the analysis.
3) From the “Field” menu, select “Summarize”. In the “Summary Table Definition” window, enter
the following parameters:
o Specify output file as
“mimals12-landuse.dbf”
o Field: “AREA”
o Summarize by: “SUM”
o Click on the “Add” button so
that the command
“SUM_AREA” appears in
the box on right.
o Click “OK” to create the
summary table.

The resulting summary table should be identical to the table
shown here. The count represents the number of polygons in
sewershed MIMALS12 with that land use code.

NOTE: The last record in the table has no SLAMMCODE. This is the total area of land uses
(roads and water) for which there was no SLAMMCODE. SLAMM does not consider roads and
water as separate land uses, so this is not a problem.
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D. Data Consistency Check: Total Land Area
In this step, verify that the total land area in the summarized table equals the total area of the
sewershed.
1) Open the new table (mimals12-landuse.dbf), if not already open.

2) In the table, activate the “Sum_Area” field by clicking
on the gray box at the top of its column.
3) From the “Field” menu select “Statistics”.
4) Write down the sum, which is the total land area. Close
the statistics window by clicking “OK”.

5) Open the view window and activate the sewershed theme “Maluswb.shp” (click on its name so that
it appears raised).
6) From the menu line, select the “Identify” button. Click on the MIMALS12 sewershed;
compare the area to the sum from the table.

In previous runs, the total area from the summarized table was 25,457,464 square feet, while
the area of sewershed MIMALS12 was 25,457,704 square feet. The difference (240 square
feet) was only 0.001% of the MIMALS12 sewershed area – an insignificant difference
probably attributable to slight edge mismatches where there was no land cover information
inside the sewershed.

III. Reformat Land Use Statistics for Use in SLAMM
A. Add a Field for Sewershed Name to the Summarized Land Use Table
1) With the new “mimals12-landuse.dbf” table open, select “Start Editing” from the “Table” menu.
2) From the “Edit” menu select “Add Field”. In the “Field
Definition” box, enter the following:
o Name: “Basin”
o Type: “String”
o Width: “4”
o Click “OK” to continue.
3) From the “Field” menu select “Calculate”.
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4) In the window titled “[Basin] =”, enter
“0012” (include the quotations, because
the BASIN field is a character string, not a
numeric value).
Click “OK”.
5) Examine the table; all records in the Basin field should equal 0012.
NOTE: This exercise deals only with the sewershed MIMALS12. If all sewersheds were to be
studied, it would be much more efficient to produce a single land use summary table. This is more
complicated, however. In the “Maluswb” theme table, a unique identifier for each sewershed /
SLAMMCODE combination would be needed (for example, a new item in the “Maluswb” table =
Sewershed name + SLAMMCODE, which would have values such as MIMALS12A, MIMALS12B,
etc.). The entire table (not just records from a selected sewershed) would be summarized using
the unique identifier field. The items ID (sewershed ID), SLAMMCODE and SUM_AREA would
need to be included in the generated summary table.

B. Convert Area from Square Feet to Acres
1) Activate the “mimals12-landuse.dbf” table.
2) From the “Edit” menu select “Add Field”. If the “Add Field” option is blocked, select “Start
Editing” again from the “Table” menu.
3) In the “Field Definition” window, enter the following
parameters:
o Name: “Acres”
o Type: “Number”
o Width: “8”
o Decimal Places: “1” (NOTE: Historically, SLAMM
has not handled more than one decimal place!)
o Click “OK” to continue.
4) From the “Field” menu select “Calculate” or
click on the “Calculate” button.
5) In the “Field Calculator” window enter the following
equation: [acres] = “[Sum_area] / 43560”. This is the
conversion from square feet to acres. Click “OK”.
6) Save the edits to the attribute table. From the “Table”
menu, select “Stop Editing” and confirm the process.
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7) Save the project.

C. Adjust Land Use Area Totals to Incorporate Road Areas
The total road area is calculated from Marquette’s land use data, but SLAMM does not treat roads as a
separate land use. Instead, the standard land use files for SLAMM incorporate adjacent road area into
each land use. To rectify this, either the SLAMM data format must be altered or an algorithm must be
developed to incorporate road area into adjacent land uses.
The latter method, a “road folding” algorithm, was developed for the Lake Superior Non-Point project
using the Arc Marco language (AML) in the Arc/Info GIS software. However, AMLs do not function
in ArcView. A similar algorithm could be developed using ArcView’s macro language, called a
“script”.
In the meantime, a lookup table will be used that contains the road folding factors for the sewershed
MIMALS12. Otherwise the 61 acres of roads in the MIMALS12 sewershed would be unaccounted for,
and runoff and pollutant loads would be underestimated.
In the following steps we will join the “roadfactor-mimals12.dbf” table to the “mimalu12-landuse.dbf”
table, to relate the road area factors to each land use.
1) From the project window (Marqslamm.apr), select the “Tables” icon and press “Add”. Navigate to
the “roadfactor-mimals12.dbf” file and click “OK”.
2) In the “roadfactor-mimals12.dbf” table, activate the “SLAMMCODE” field (click on its gray
header bar).
3) Open and activate the “mimals12-landuse.dbf” table. In the attribute table, select the
“SLAMMCODE” field (click on its gray header bar).
4) From the “Table” menu select “Join”. Examine the “mimals12-landuse.dbf” table; it should have
an additional field for the road factor.
5) Next we will determine the total area (including roads) per land use by multiplying the area per
land use by the road factor.
From the “Table” menu, select “Start Editing”.
6) In the “mimals12-landuse.dbf” table, select “Add Field” from the “Edit” menu. In the “Field
Definition” window enter the following parameters:
o Name: “Total_Ac”
o Type: “Number”
o Width: “8”
o Decimal Places: “1”
o Click “OK” to continue.
7) From the “Field” menu select “Calculate”.
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8) In the “Field Calculator” window, enter the
following expression: [Total_Ac] = [acres] *
[Roadfactor]
9) Click “OK”.

NOTE: After applying this type of area conversion factor, total area from Total_Ac could again
be compared to the total sewershed area (excluding water) from the Maswbnd.shp theme, to make
sure the total area was not significantly different. Previous checks gave a sum of Total_Ac =
584.5 acres, compared to the Maswbnd.shp total for MIMALS12 of 25,457,704 square feet, or
584.43 acres (a 0.01% difference).
10) Since SLAMM does not consider roads or water bodies as distinct land use categories, these
records will be deleted from the table.
11) In the “mimals12-landuse.dbf” table, select (click on) the record which has no “SLAMMCODE”
value. From the “Edit” menu select “Delete Records”.
12) From the “Table” menu, select “Stop Editing”. Choose “Yes” to save the edits.

D. Add Fields for Soil Type (Sand or Clay)
The SLAMM input file requires that for each land use, the soil type (sand or clay) be specified. In this
exercise, all soils are assumed to behave like clay. Since urban soils are typically compacted for
construction, even sandier soils tend to be less permeable and behave more like clay. Assuming all
soils behave like clay gives a higher estimate of runoff and pollutant loading due to the lower water
infiltration rate of clay soils.
If spatial soils data were intersected with the land use and sewershed theme, the land use summary file
generated so far could further specify the relative proportion of sandy and clayey soils underneath each
land use. For example, of a hypothetical 103 acres of park (code H), 90 acres could be specified on
sandy soils and 13 acres on clayey soils in this city.
SLAMM, however, is not currently configured to allow different soil types for a given land use. For
each land use (such as code “H” for parks), the SLAMM Standard Land Use file already has soil types
assigned for each source area. For example, the Standard Land Use file for parks says that a park
typically contains some playground source area which drains onto sandy soil. If the summary file we
produce indicates that there are some parks on clay soils, this will conflict with the sandy soil
reference, and SLAMM will not process the data.
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So in summary, a GIS analysis could easily produce detailed information about which soils are actually
underneath each land use in a study area, but SLAMM wouldn’t consider the information because soil
type is already coded into the Standard Land Use files. Instead, redundant data (reaffirming the soil
type) must be included in the land use summary file.
How Madison Handled Soils in SLAMM
The City of Madison, Wisconsin Engineering Department defined all soils as sand instead of
clay. However, runoff coefficients (RSV file) for “sandy” soil were calibrated using actual
rainfall and runoff measurements for the land use/source area combinations in Madison.
Thus Madison soils were not necessarily considered sandy. The “sand” classification assigned
to Madison soil was just an identifier which linked land use/source area data to Madisonspecific runoff coefficients. For more information, contact Greg Fries in Madison’s
Engineering Department.
1) Open the “mimals12-landuse.dbf” table. Choose to “Start Editing” from the “Table” menu. Select
“Add Field” from the “Edit” menu. In the “Field Definition” window, enter the following
parameters:
o Name: “Sand_Ac”
o Type: “Number”
o Width: “8”
o Decimal Places: “1”
o Click “OK” to continue.
2) In the table, activate the “Sand_Ac” field
(click on its gray header bar). From the
“Field” menu select “Calculate”.
3) In the “Field Calculator” window, enter the
following equation “[Sand_Ac] = 0”
Click “OK”. (No land area is sandy soil.)
4) Again in the “mimals12-landuse.dbf” table, select “Add Field” from the “Edit” menu. Enter the
following parameters:
o Name: “Clay_Ac”
o Type: “Number”
o Width: “8”
o Decimal Places: “1”
o Click “OK” to continue.
5) In the table, activate the “Clay_Ac” field
(click on its gray header bar). From the
“Field” menu select “Calculate”.
6) Enter the following equation “[Clay_Ac] =
[total_ac]” in the “Field Calculator”. Click
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“OK”. (All soil is assumed to behave like clay.)
E. Save Changes and Export Table
In order to permanently relate (join) the SLAMM code and road factor fields from the other tables, this
table must be “exported” under a different name.
1) With the “mimals12-landuse.dbf” table active, from the “Table” menu select “Stop Editing”. Save
all edits.
2) From the “File” menu select “Export”; in the “Export Table” window set the “Export Format” to
“dBASE”. Click “OK”.
3) Save the file as “Mimals12.dbf”.
4) In the “mimals12-landuse.dbf” table “Stop Editing” from the “Table” menu, “Save Edits” and close
the table.
5) Save the project.

F. Delete Unnecessary Fields from the Table
In this step, we will delete unneeded data from the mimals12 database file.
1) Open the exported table (Mimals12.dbf). To do so, go to the project window (Marqslamm.apr);
select the “Table” icon and press “Add”. Navigate to the “Mimals12.dbf” file and press “OK”.
2) With the table open, from the “Table” menu select
“Start Editing”.
3) Select the “Count” field (click on its gray header
bar); from the “Edit” menu select “Delete Field”.
Click “Yes” to confirm the operation.
4) Repeat the process to delete the fields: “Sum_Area”,
“Acres”, “Lu” and “Roadfactor”.
5) Move “Basin” field to the first column, by clicking
and holding on its grey header bar, and dragging it
to the left of the “Slammcode” field.
6) From the “Table” menu select “Stop Editing”. Save
the edits. The final table should look like the one
shown here.

G. Convert Final Table to SLAMM Format (ASCII Text File with “PLA” Extension)
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In this step, we will convert the mimals12 database file to a SLAMM .pla file, also called a “planning
level sub-basin description file” specific to SLAMM.
1) With the “Mimals12.dbf” table active, from the “File” menu select “Export”. In the “Export
Table” set “Export Format” to “Delimited Text”. Click “OK”.
2) Save the file as “mimalu12.txt”.
3) Close the “Mimals12.dbf” table.
4) Save the project.
5) Minimize ArcView with the “_”
button.
6) With a text editor (Notepad, for example), open the
“mimalu12.txt” file. Delete the header information in the first
line of the file.
7) Save the “mimalu12.txt” file and close the text editor.

8) Use the Windows Explorer to change
the name of the file to “Mimalu12.pla”.
Select “Yes” to change the name, if
warned about changing the file
extension.

IV. Create or Obtain Appropriate SLAMM Parameter Files
Make sure the SLAMM Standard Land Use files (which specify the typical land use, source area and
runoff behavior data for a given general land use) are in the working directory. See the table below for
a list of files. (Note: The files needed are bolded.)
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We will use existing parameter files for Marquette, Michigan. Verify that the files are also in the
project directory: “Marq4.ppd”; “Marq.psc”; “Marq.prr”; “Marq.ran”; and “Marq.rsv”. These files
must be in this specific directory because their location is coded into the header of each SLAMM
Standard Land Use file.
Note: since this exercise doesn’t use the detention pond analysis module (DETPOND), a
particulate size file (.CPZ extension) is not needed.

V. Modify Standard Land Use Files in SLAMM for Needed Land Use
Categories
(This step has already been completed for this exercise.)
Our land use summary file (Mimalu12.pla) uses the SLAMMCODE to reference the relevant SLAMM
Standard Land Use file (see table). If the Standard Land Use files do not have the appropriate
SLAMMCODE in their Site Description line, SLAMM won’t know which SLU file to associate with
which SLAMMCODE land use. This has already been done for this exercise. See the SLAMM
documentation for more information.
SLAMM Standard Land Use Files (Files in bold text are used in this exercise)
"LU" Land
Use Code
CDT
CEM
CST
FREE
HOSP
HRNA
HRWA
LI
LR
MF
MI
MISC
MOBR
MRNA
MRWA
OP
OSUD
PARK
SC
SCH

SLAMMCODE

Land Use Description

SLU File Name

S
K
F
G
U
M
N
O
C
D
E
J
P
A
B
T
I
H
R
Q

Commercial Downtown
Cemetery
Commercial Strip
Freeway
Hospital
High Density Residential (no Alley)
High Density Residential (with Alley)
Light Industrial
Low Density Residential
Multi-Family Residential
Medium Industrial
Miscellaneous
Mobile Homes
Medium Density Residential (no Alley)
Medium Density Residential (with Alley)
Office Park
Open Space
Park
Shopping Center
School

SLUCDT.DAT
SLUCEM.DAT
SLUCST.DAT
SLUFREE.DAT
SLUHOSP.DAT
SLUHRNA.DAT
SLUHRWA.DAT
SLULI.DAT
SLULR.DAT
SLUMF.DAT
SLUMI.DAT
SLUMISC.DAT
SLUMOBR.DAT
SLUMRNA.DAT
SLUMRWA.DAT
SLUOP.DAT
SLUOSUD.DAT
SLUPARK.DAT
SLUSC.DAT
SLUSCH.DAT

VI. Run the SLAMM Batch Editor to Estimate Pollutant Loadings
1) Start the SLAMM program.
o Start  Programs  WinSLAMM  WinSLAMM
o Or, run the file c:\Program Files\winslamm\winslamm.exe
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2) A guiding screen will open for the
program. Start this project by
clicking “Enter Main Screen”.
3) From the SLAMM menu (at the top
of the screen), select “Run”. From
the pull-down menu select “Run
Batch Editor”.
In the warning screen that appears,
choose “Yes” to delete any data that
has been entered in the WSLAMM
Input Module.

4) In the Batch Editor menu, select “Options”. From the pulldown menu, choose “Select Path for Source Land Use Files”.

5) In the window that appears, navigate to the project directory that was set as the working directory in
ArcView. This directory will contain the marqslamm.apr and associated files. Click “Ok”.

At this point, the
Standard Land Use
(SLU) files should
appear in the right
window of the
Batch Editor.
If the files do not
appear, select the
“Land Use Soils
Type” as “Silty” by
placing a dot in
front of the class.

GIS & SLAMM: Page 20 of 27

In the Batch Editor, each record from our “Mimalu12.pla” file (called the “planning level sub-basin
description file” in SLAMM) references a Standard Land Use (SLU) file. The Standard Land Use files
are used to generate the runoff and loading values. Acreage in each SLU file is proportioned to equal
the acreage from the record in the PLA file.
All of the adjusted SLU files are then run as a batch using the DOS SLAMM Calculations module.
The output from the batch processor run is a comma separated value (CSV) file that summarizes, for
all rain events in the model run, the total runoff, the particulate loading, and the selected pollutant
loadings from SLU in the batch run.
MIMALU12.PLA file
0012,H,39.7,0.0,39.7
0012,F,37.6,0.0,37.6

SLAMM Standard Land Use file
SLUPARK.DAT
SLUCST.DAT

Runoff & Loading report
MIMALU12.CSV

Note: The SLAMM Batch Editor is used here to process multiple land use areas (H,F,Q, etc.)
within the same sewershed (0012). It can also be used to process single or multiple land use areas
from different watersheds/sewersheds, using the same PLA file. In that case, statistics are totaled
by sewershed in the CSV output file.
6) In the Batch Editor window
set the output directory.
This is done by choosing
“Select Destination Path for
File Creation” from the
“Options” pull down menu.
In the next window, navigate
to the project directory
(marqslamm) and select
“Ok”.
7) In the Batch Editor window,
select the bottom “Create”
button to “Create a series of
SLAMM.DAT files from a
Land Use Database”.
8) Select the “Mimalu12.pla”
file.
SLAMM should perform its final calculations and produce the comma-separated value (CSV) file. The
format of this file includes a header that lists total runoff (c.f.), particulate solids (lbs), and the loadings
for the selected pollutants. The total runoff, total particulate solids, and total pollutant loadings for
each sub-basin are then listed. This file can be imported into a computer spreadsheet for further
analysis.
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David- Here is where I have problems. WinSLAMM will not run for
me. I keep getting the following error:
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VII. Display Output in GIS
In addition to preparing input data for models, GIS is well suited for spatial analysis of model results.
This is demonstrated using a previously generated SLAMM output file for all of the Marquette
sewersheds (not just MIMALS12).
A. Modify SLAMM Output for Use in GIS
Two main modifications must be made to the SLAMM output file so that it can be displayed in a GIS.
These can be made in common spreadsheet or database software.
Sewershed Key: An item (column) must be added with the same sewershed name as in the spatial
sewershed theme (in our case, MIMALS11, MIMALS12, etc.)
Data Aggregation: If it is desired to see a single runoff and loading total for each sewershed, multiple
records (rows) for different land uses in the same sewershed must be aggregated into one. For
example, the output file for this exercise would have 12 records for the sewershed MIMALS12 alone
(one for each land use in that sewershed). Those 12 records would have to be summed into a single
record for sewershed MIMALS12.
If it is desired to see the breakdown of runoff and loading per land use in a sewershed, then the table
should no be aggregated. However, because such a table could have many records per sewershed, the
method of relating the table to the sewershed theme is different ( a “link” instead of a “join” –
explained below).
B. Relate SLAMM Output to Sewershed Polygons
To display the SLAMM output spatially, each record must be assigned to a sewershed polygon.
1) Restore the ArcView project.
2) From the “Window” menu, select “Marqslamm.apr”. In the project window that opens, select the
“Tables” icon and press “ADD”. Navigate to the “Mimaloads.dbf” table and “OK” to add the
table.
3) In the “Mimaloads.dbf” table, activate the “ID” field (click on its grey header bar).
4) Open the “View: Land Use & Sewersheds” window, from the “Window” command. Activate the
sewershed theme “Maswbnd.shp” by clicking on its name in the legend. From the “Theme” menu,
select “Table” to open the attribute table.
5) In the “Maswbnd.shp” table, activate the “ID” field (click on its grey header bar). (Be sure that no
records are selected.)
6) From the “Table” menu, select “Join”.
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NOTE: If it is desired to see a breakdown of runoff or loadings per land use within a sewershed,
a non-aggregated table of SLAMM output must be :linked” to the sewershed theme. In this case,
there are many records (one per land use) in the SLAMM output table which are related to a
single sewershed. Under a “link” relation (instead of the “join” used above), the sewershed
polygons cannot be color coded using the SLAMM output data, as done below. However, if a
sewershed polygon is selected in the sewershed theme, all associated records will automatically
be selected in the SLAMM output table. These selected records can then be analyzed.
C. Classify Sewershed Theme According to Runoff and Loading Values
1) In the “View: Land Use & Sewersheds” window, turn on the sewershed theme “Maswbnd.shp”.
Open the Legend Editor by double clicking on the theme name.

2) In the Legend Editor, set the following
parameters:
o Legend Type = “Graduated Color”
o Classification Field = “Solids” (total
solids in pounds)
o Press the “Classify” button; set the
Number of Classes to “5”; press OK
o Press the “Apply” button
o Close the Legend Editor and return to
the sewershed theme.

3) Next, add sewershed names for reference.
In the view window, activate “Maswbnd.shp” (click on its name in
the legend so the entire name has a raised box around it).
From the “Theme” menu, select “Auto Label”.
Select “OK” in the Auto Label window.
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4) Next, re-classify the sewershed theme according
to total solids divided by sewershed area.
Turn on the sewershed theme “Maswbnd.shp” (if
not all ready). Double click on the theme name to
open the Legend Editor.
In the Legend Editor, change the following
parameters:
o Normalize by “Area” (solids divided by
sewershed area = solids per area)
o Press the “Apply” button.
o Close the Legend Editor.

5) Re-classify the sewershed theme using pollutant loadings (phosphate):
Again, open the Legend Editor for the sewershed
theme, “Maswbnd.shp”.
In the Legend Editor, set the following parameters:
o Legend Type = “Graduated Color”
o Classification Field = “Phosp”
o Normalize by “<None>”
o Press the “Classify” button. Set the
Number of Classes to “5”; press “OK”.
o Press the “Apply” button.
o Close the Legend Editor to return to the
sewershed theme.
6) Examine the distribution of different pollutant loadings (both in total pounds, and pounds per area
using the Normalize option). You will likely see different distributions, because different land
uses/source areas generate different pollutants.
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Conclusions/Issues
GIS can be used to easily and accurately total the land area within each sewershed having a given land
use. Beyond that, however, runoff and sediment/pollutant loading calculations in SLAMM are
dependent on parameters assigned to those land use classes. In particular, two key questions are:
1. Are the Standard Land Use files (e.g. SLUPARK.DAT for parks) a good enough estimate for the
distribution of source area types and soils present in the study area? Remember that within the
Standard Land Use files, source area/soil relationship cannot be changed merely by specifying a
different soil type for a given land use in the PLA file.
2. Are the parameter files (ran, ppd, prr, rsv, psc, cpz) representative of the study area?

Bugs in SLAMM Version 8.0 (as of December 12, 1999)
•

Batch Editor won’t Produce Output Summary: The final summary (CSV) is not produced.
Intermediate files are produced. The Standard Land Use files, proportioned to actual acreage), but
these are erased when the Batch Editor is closed.

•

Update Compatability: SLAMM Version 5 land use (DAT) files are not compatible with the
version 8 program. Supposedly there is an import module to convert them, but this was not
encountered by the authors.

•

ASCII-Format Text File Errors: Sometimes SLAMM won’t recognize the Planning agency land
use (PLA) file or parameter files if they were saved using the Notepad program (even if saved as an
ASCII-format text file). It is readable if saved by the DOA EDIT editor, but not if there is an extra
carriage return at the end of the file. However, SLAMM has no problem reading the DAT files
modified and saved using Notepad.

Appendix A: Summary of SLAMM Parameters
Land Use Source Areas (*.DAT file)
The area (acreage) and runoff behavior of each type of “source area” within each land use class is
compiled here. Areas are defined by the following criteria:
• Land use (6 classes: residential, institutional, commercial, industrial, open, and freeways)
• Source area within each land use (14 types, such as roofs, parking, playground, landscaped,
streets…)
• Source area properties affecting runoff (for example: pitched or flat roof, direct or indirect
connection to storm sewer, soil type, building density, presence of alleys, street texture)
Note: in this exercise we are using GIS to compile only the acreage totals for each land use. We
will use SLAMM’s batch processing module, which accesses existing Standard Land Use files to
compute expected source area distributions and runoff behavior within each general land use.

GIS & SLAMM: Page 26 of 27

g

Rain Events (*.RAN file)
Necessary rain information includes rain depths, durations, and interevent time periods. This
information can be recorded from rainfall records or generated stochastically from rainfall statistics.
Runoff Coefficients (*.RSV file)
Runoff coefficients, when multiplied by rain depths, land use source areas, and a conversion factor,
determine the runoff volumes. RSV coefficients are a function of:
• Source area type (9 types, such as roof, pervious, impervious, streets)
• Rainfall depth (17 levels, from 1 to 125 mm)
• Drainage Efficiency Factor (3 levels for how directly runoff connects to storm sewer)
Particulate Solids Concentration (*.PSC file)
Particulate solids concentration values, when multiplied by source area runoff volumes and a
conversion factor, calculate particulate solids loadings (in pounds). PSC values are a function of:
• Land use (6 classes)
• Source area type (13 types)
• Rainfall depth (14 levels, from 1 to 80 mm)
Pollutant Probability Distribution (*.PPD file)
Pollutant probability distribution values determine, when multiplied by either a source area runoff
volume or source area particulate loading, the pollutant loading from a source area. These
concentrations are ideally based on measurements specific to the study area. SLAMM calculates
pollutant loadings for nine particulate and ten filterable pollutants. The user may define up to six other
pollutants in both particulate and filterable forms. PPD values are a function of:
• Land use (6 classes)
• Source area type (14 types – PSC types, plus streets)
Particulate Residue Reduction (*.PRR file)
This describes the fraction of total particulates that remains in the drainage system (curbs and gutters,
grass swales, and storm drainage) after rain events end due to deposition. Residue reduction is a
function of:
• Type of drainage system (grass swales; undeveloped roadside; curb & gutters, ‘valleys’, or sealed
swales)
• Condition of curb and gutter (poor/flat, fair, or good/steep)
• Rainfall depth (14 levels, from 1 to 80 mm)
Particle Size (*.CPZ file – only for detention pond analysis)
This information describes the size distribution of urban runoff particulates that enter a detention pond.
Particle size determines the amount of settling in the pond, and how much particulate will continue as
runoff.
Stochastic Pollution Generation (optional Monte Carlo uncertainty simulation)
To model uncertainty in pollutant concentrations, a stochastic number generator in the model generates
lognormally distributed pollutant values. These values are based upon the pollutant mean and the
pollutant coefficient of variation (COV) for the selected land uses and source areas.
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